WARNING: This product contains nicotine. Nicotine is an addictive chemical.

MEMORIAL DAY SALE!
Save 15% - Sale Code: HONOR15 - All E-liquids thru 5/27 Midnight Eastern

Heather’s Points

No Heather’s Points earned yet on current order.
Log in to see how many Heather’s Points you have already earned

Newsletter

Subscribe to our newsletter for news and special sales.

Email:

Secure Ordering

Taking The Lead In Secure Shopping

Ensuring The Safest Online Shopping Experience

Heather's Heavenly Vapes continuously updates our site's security protocols to the highest standards. We do all we can to ensure that all your personal data and credit card information remains as safe as possible.

Taking The Lead

HHV takes the lead on security by being among the first online companies to implement new protocols. Eventually, everyone who sells goods or services online needs to meet new protocols as well.

Having Trouble Ordering?

We apologize for the inconvenience. Any computer or device that you are using that does not meet required protocols cannot establish a secure connection with the HHV website. Updates will be needed.

Here is a short list of software that does not meet the latest protocols:

  • IOS 5 and older
  • Safari 5.1 and older
  • Kindle Fire
  • Android 4.4 and older
  • OS X v10.8 (Mountain Lion) and older
  • Windows XP and older
  • Many older browsers do not contain the TLS 1.2 security protocols. For instance, older versions of Chrome, Internet Explorer, Firefox, etc.

What Can You Do?

Be sure you upgrade your browser to the latest version that is available. This will not only allow you to order from HHV, but make your shopping experience with other sites that are running these protocols smooth as well.

Windows Users

If you use Internet Explorer 8, 9, or 10 you will need to make some simple changes to your Internet Explorer browser settings.

  1. On the Internet Explorer main menu, select Tools > Internet Options.
  2. In the Internet Options box, select the Advanced tab.
  3. In the Security category, uncheck Use SSL 3.0 and check Use TLS 1.0, Use TLS 1.1, and Use TLS 1.2 (if available).
  4. Click OK.
  5. Exit and restart Internet Explorer.

Note it is important to check consecutive versions. Not selecting consecutive versions (for example, checking TLS 1.0 and 1.2, but not checking 1.1) could result in connection errors.

Mac Users

To update Safari 6.x, you need to update from Mountain Lion. It's free! Learn more here.